This message appears when you use a quite old version of Billdu. Some features are available only with newer versions of Billdu and the stability of data synchronization is improved with every version. If you use a deprecated app (v 4.1.10 an older) this error message might appear and we urge you to update your application in App Store. You may also want to check on the Billdu website if all your data has been synchronized correctly.

Billdu iOS app needs iOS 10 or higher in order to work correctly. Older operating systems such as iOS 9 or 9.3.5 are not supported. You will be able to download an older version of Billdu from App Store but we can't guarantee it will run smoothly and error-free.

Take a look here to learn more about Billdu's system requirements.

Did this answer your question?